Verification is currently underway for the maintenance items.
Posted Jan 04, 2026 - 07:35 GMT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 04, 2026 - 05:00 GMT
Scheduled
We're giving Learn Amp some well-deserved TLC this Sunday morning.
Here's what's happening: we're upgrading our database engine and applying important security patches. These improvements will make your Learn Amp experience faster and more secure.
What this means for you: • Learn Amp will be briefly unavailable • Expected duration: 2-4 hours • Start time: 5AM GMT
We'll keep you posted right here with live updates throughout. Thanks for bearing with us - it'll be worth it!
Posted Dec 12, 2025 - 21:25 GMT
This scheduled maintenance affected: EU1 (Learn Amp Main Web App - EU1, Learn Amp API - EU1) and EU2 (Learn Amp Main Web App - EU2, Learn Amp API - EU2).